win10下安装scrapy出现错误的处理

系统是WIN10 64位
Python是3.5.2
今天安装pip install Scrapy  来安装
发现报错Microsoft Visual C++ 14.0 is required

检查发现电脑中其实是有Microsoft Visual C++ 14.0的,但是无论怎么都无法安装成功

后来解决办法是使用文件来安装

1、下载Scrapy安装文件

2、使用命令pip install wheel 安装这个

3、将CMD切换到Scrapy文件所在目录,使用pip install ******.whl 的方式安装

4、可以使用pip install Scrapy 检验一下是否安装成功


一、背景:

      在win10的dos窗口下使用命令pip install scrapy安装scrapy时,出现“ error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: https://visualstudio.microsoft.com/downloads/”的错误提示,安装不成功。

二、处理过程:

1、根据提示在微软网站安装了Visual Studio套件中的C++build组件,仍未能解决问题。

2、网上寻找帮助,在“https://blog.csdn.net/doyanger/article/details/54235203”页面看到,出现错误提示主要是组件lxml组件未能安装成功(再查看安装的错误提示,发现在error前面有“building ‘lxml.etree’ extension”的关键词,说明的确是在安装lxml组件时出现的问题),可在“http://www.lfd.uci.edu/~gohlke/pythonlibs/#lxml”网站直接下载对应版本的lxml组件进行安装。

3、在“http://www.lfd.uci.edu/~gohlke/pythonlibs”页面查找lxml的关键词,可看到一系列的lxml组件,选择“lxml‑4.4.1‑cp38‑cp38‑win_amd64.whl”组件下载,并放在目录“c:\Users\Administrator\”下。进入dos窗口(运行输入cmd,自动进入dos的管理员模式),输入命令“pip install ./lxml‑4.4.1‑cp38‑cp38‑win_amd64.whl”,即可完成lxml组件的安装。

4、在lxml组件安装完成后,重新执行pip insall scrapy命令,发现还需要安装twisted组件,安装上述方法下载“Twisted-19.7.0-cp38-cp38-win_amd64.whl”,执行“pip install ./Twisted-19.7.0-cp38-cp38-win_amd64.whl”安装。

5、上述组件安装完成后,继续执行pip install scrapy,不再出现红色错误提示,表明安装成功!

三、小结

  lxml和twisted组件都是scrapy的关键组件,win10下直接安装需要C++build编译支持,应该是安装的C++build工具不完整吧,未能直接安装成功,后续再找机会测试。使用网上的对应系统编译好的成品组件安装lxml和twisted也是好的办法,既解决了问题也节约了时间。 

发表评论

邮箱地址不会被公开。 必填项已用*标注